Degraded Email Performance

Incident Report for Ruvna

Resolved

This incident has been resolved. Email delivery is functioning as-expected.
Posted Jul 24, 2020 - 10:58 EDT

Investigating

We are currently investigating this issue.
Posted Jul 24, 2020 - 10:16 EDT