SMS Delivery Delays to T-Mobile
Incident Report for Ruvna
Resolved
Our provider has resolved the issue and there are no longer delivery delays when sending messages to T-Mobile devices.
Posted Jan 27, 2021 - 11:45 EST
Investigating
Our upstream provider, Twilio, is currently experiencing an issue which is causing SMS delivery delays when sending messages to T-Mobile US devices via short codes. Ruvna delivers text messages through a short code, so text messages (including Health screenings and Announcements) may be delayed for users with T-Mobile devices. See https://status.twilio.com/incidents/8961zbmdjfxr for more details.

We will resolve this incident once we have received confirmation the issue has been resolved from our upstream provider.
Posted Jan 27, 2021 - 10:50 EST
This incident affected: Ruvna Notifications (SMS Notifications).