Data Import operations facing delays

Incident Report for Ruvna

Resolved

Data syncing functionality has been fully restored and is stabilized.
Posted Oct 20, 2025 - 16:32 EDT

Monitoring

All pending data syncs have now been completed, and further syncs are running normally as we continue to monitor things closely.
Posted Oct 20, 2025 - 15:56 EDT

Identified

Due to ongoing network interruptions with an upstream provider, Ruvna data import sync operations are facing delays and in some cases are being paused. We're investigating and will update this page with more details as the delays are resolved.
Posted Oct 20, 2025 - 14:50 EDT
This incident affected: School Data Import (Ruvna Data Import).