This incident has been resolved. All systems are operational.
Posted Sep 22, 2026 - 12:00 EDT
Update
The SIS partner's API that was exhibiting errors and timeouts is becoming stable again, resulting in data syncs being resumed as well as enqueued attendance writeback update being dispatched successfully. We are monitoring the results.
Posted Sep 22, 2026 - 11:23 EDT
Update
The SIS partner's API that was exhibiting errors and timeouts is becoming stable again, resulting in data syncs being resumed as well as enqueued attendance writeback update being dispatched successfully. We are monitoring the results.
Posted Sep 22, 2026 - 11:21 EDT
Monitoring
The SIS partner's API that was exhibiting errors and timeouts is becoming stable again, resulting in data syncs being resumed as well as enqueued attendance writeback update being dispatched successfully. We are monitoring the results.
Posted Sep 22, 2026 - 11:20 EDT
Update
We are continuing to investigate, and working on a fix for this issue. We will share updates here as they become available.
Posted Sep 22, 2026 - 11:02 EDT
Update
We are continuing to investigate, and working on a fix for this issue.
Posted Sep 22, 2026 - 10:32 EDT
Update
We are continuing to work on a fix for this issue.
Posted Sep 22, 2026 - 09:59 EDT
Identified
We are seeing elevated errors and timeouts from one of our SIS partners' APIs, which appears to be the source of these delays. Imports for schools on that platform are taking far longer than normal to complete, and because SIS jobs share a processing queue, that backlog is delaying schools on other SIS platforms as well.
This is also broader than our first update indicated. In addition to delays importing data into Ruvna, SIS writeback from Attendance is delayed. Attendance recorded in Ruvna is not currently posting back to your SIS on the usual schedule.
Attendance taken in Ruvna is saved and accurate, and nothing needs to be re-entered. Pending records will write back to your SIS once the queue clears. Taking attendance, viewing rosters, and all other Ruvna features continue to work normally.
We are working to limit the impact of the affected imports on the rest of the queue and are monitoring our partner's status.
Posted Sep 22, 2026 - 09:28 EDT
Investigating
We are investigating delays in SIS data syncs into Ruvna.
Posted Sep 22, 2026 - 09:12 EDT
This incident affected: School Data Import (Ruvna Data Import, Blackbaud API Sync) and Ruvna Core Systems (Attendance).